Installing the Fax Merge Macros (MS Word and OpenOffice.org)

Administrator -

Where to obtain and how to install these additional faxing tools on a workstation.

Introduction

All the tools needed for installing the fax merge macros are available on the user's computer once a Windows client application is installed (see Fax Integration with Windows Clients). By default, these tools can be found at the following path: C:\Program Files\XMediusFAX\Client\MailMerge.
Note: The installation depends on the text application used (MS Word or OpenOffice.org), and on its version. Therefore, several installation procedures are described here.
Important: To ensure that the fax merge macros function properly, when you install MS Office, make sure the Visual Basic for Applications (VBA) component is installed along with it.

Installation Procedure for Microsoft Word 2003 or Earlier Versions

  1. Open Microsoft Word.
  2. In the menu bar, select Tools > Options, then select the Security tab.
  3. Click Macro Security.
  4. If the selected option is Very High or High, select the Medium option and click OK.
  5. Click OK.
  6. Open the document xmmerge.doc located in the <install_path>\Client\MailMerge\en folder.
  7. Click Enable Macros.

    The document opens with a single button: Install the fax server macros.

  8. Click on the button to launch the installation.

    After the installation, the new toolbar with two buttons appears at the top right of the Microsoft Word window.

    If the macro security was changed to allow this installation, it should be set again to its original level, as shown at the first steps of the procedure.

Installation Procedure for Microsoft Word 2007 / 2010

  1. Go to the <install_path>\Client\MailMerge folder.
  2. Run the WordRibbonSetup.exe file.

    A dialog with three buttons (Install the MS Word Fax Add-In, Uninstall the MS Word Fax Add-In and Exit) is displayed.

  3. Click Install the MS Word Fax Add-In.
  4. After the installation, start Microsoft Word.

    A new tab Fax should appear in the ribbon, and under this tab, two functions: Send Fax and Fax Merge.

    To use these functions, please refer to the XMediusFAX User Guide.

Installation Procedure for OpenOffice.org

  1. Open OpenOffice.org Writer.
  2. In the menu bar, select Tools > Options, then select the OpenOffice.org > Security node.
  3. Click Macro Security.
  4. If the selected option is Very High or High, select the Medium option and click OK.
  5. Click OK.
  6. Open the faxmacros.sxw document located in the <install_path>/Client/MailMerge folder.
  7. Click Enable Macros.

    The document opens with two buttons: Install fax macros and Uninstall.

  8. Click on the Install fax macros button to launch the installation.
    After confirmation, the macros are installed.
    Note: A message box indicates that you must close and restart OpenOffice.org and the quick launch bar (icon at the bottom-right of the screen) in order for the installation to be effective.
  9. Restart OpenOffice.org Writer.

    The Fax menu, containing the FaxBroadcast and SendFax submenus appears now between the Tools and Window menus.

    If the macro security was changed to allow this installation, it should be set again to its original level, as shown at the first steps of the procedure.

Have more questions? Submit a request

Comments

Powered by Zendesk